Next.js- The React Framework

The React Framework https://nextjs.org   Visit nextjs.org/learn to get started with Next.js. The below readme is the documentation for the canary (prerelease) branch. To view the documentation for the latest stable Next.js version visit nextjs.org/docs How to use Setup Automatic code splitting CSS Built-in CSS support CSS-in-JS Importing CSS / Sass / Less / Stylus files Static file serving (e.g.: images) […]

Use Events – Events Turned Into React Hooks.

🍭 Event hooks Use Events – Events turned into React Hooks. Read about Hooks feature. Documentation https://sandiiarov.github.io/use-events List of hooks useActive useClickOutside useFocus useHover useMousePosition useTouch Install Note: React 16.8+ is required for Hooks. With npm npm i use-events Or with yarn yarn add use-events RedQ TeamWe are a world class software startup focusing on building scalable, high-performance […]

Bulma-Modern CSS Framework Based on Flexbox

Modern CSS framework based on Flexbox Bulma Bulma is a modern CSS framework based on Flexbox. Quick install Bulma is constantly in development! Try it out now: NPM npm install bulma or Yarn yarn add bulma Bower bower install bulma Import After installation, you can import the CSS file into your project using this snippet: import ‘bulma/css/bulma.css’ CDN […]

Zero Server – Zero Configuration Web Framework

Zero is a web server to simplify web development. https://zeroserver.io/ Zero Server Zero configuration web framework. Features | Installation | Getting Started | Examples | Docs Zero is a web framework to simplify modern web development. It allows you to build your application without worrying about package management or routing. It’s as simple as writing your code in a mix of Node.js, React, HTML, MDX, and static files and putting them […]

Graphql Hooks

🎣 Minimal hooks-first GraphQL client graphql-hooks Features 🥇 First-class hooks API ⚖️ Tiny bundle: only 5.1kB (1.9 gzipped) 📄 Full SSR support: see graphql-hooks-ssr 🔌 Plugin Caching: see graphql-hooks-memcache 🔥 No more render props hell ⏳ Handle loading and error states with ease Install npm install graphql-hooks or yarn add graphql-hooks Support Latest 8 & 10 Node releases Browsers > 1%, not dead Consider polyfilling: Promise […]

Perfect Scrollbar

Minimalistic but perfect custom scrollbar plugin http://utatti.github.io/perfect-scrol… perfect-scrollbar Minimalistic but perfect custom scrollbar plugin To read documentation for versions < 1.0, please visit v0.8.1. Why perfect-scrollbar? perfect-scrollbar is minimalistic but perfect (for me, and maybe for most developers) scrollbar plugin. No change on design layout No manipulation on DOM tree Use plain scrollTop and scrollLeft Scrollbar style is fully customizable Efficient update […]

React Window Infinite Loader

React-window-infinite-loader InfiniteLoader component inspired by react-virtualized but for use with react-window Install # Yarn yarn add react-window-infinite-loader # NPM npm install –save react-window-infinite-loader Documentation Name Type Description children ({ onItemsRendered: Function, ref: React$Ref }) =&gt; React$Node Render prop. See below for example usage. isItemLoaded (index: number) =&gt; boolean Function responsible for tracking the loaded state of […]

Laravel Soft Cascade

Cascade Delete & Restore when using Laravel SoftDeletes https://medium.com/asked-io/cascading… Laravel/Lumen Soft Cascade Delete & Restore Cascade delete and restore when using the Laravel or Lumen SoftDeletes feature. Laravel laravel-soft-cascade Lifecycle ^5.5 ^5.5 January 24, 2017 Bug fixes until January 2019 Security fixes until June 2020 ^5.6 ^5.6 February 7, 2018 6 months of bug fixes 1 […]

Imagemin plugin for Webpack

Plugin to compress images with imagemin This is a simple plugin that uses Imagemin to compress all images in your project. Install npm install imagemin-webpack-plugin Requires node >=4.0.0 Example Usage var ImageminPlugin = require(‘imagemin-webpack-plugin’).default // Or if using ES2015: // import ImageminPlugin from ‘imagemin-webpack-plugin’ module.exports = { plugins: [ // Make sure that the plugin is after […]